System Requirements

In order to take advantage of all the features the INBOUND app has to offer, Javascript must be enabled and ad blockers must be disabled (some of our functionality is incorrectly identified as an ad by many ad blockers). Naturally, the internet is required too, and we recommend a strong connection for streaming sessions and entering 3D environments. For more troubleshooting tips, see this article.

The following browsers and devices are supported—you may have performance issues or be unable to use the site if you use an unsupported device.

For those using company mobile devices: If you are having trouble accessing the app, and you've verified with an INBOUND staff member that your credentials are accurate, try disconnecting from your company VPN or firewalls. Or better yet, join using a personal mobile device. Otherwise, you'll need to talk to your IT team about getting this app added to their safe list.

Supported Mobile Devices

iOS

  • iOS 14+
  • Hardware equivalent to iPhone 8, 5th generation iPad, or better

Android

  • Android 6.0+
  • Hardware equivalent to Samsung Galaxy S7, or better

Devices and Browsers with Limited Support

If you're using one of the following older devices or browsers, you may encounter a prompt to upgrade to a more recent version if you're unable to meet the performance requirements of our app.

  • iPhone 7 and lower
  • iOS 12
  • Android 4.4 and lower
  • iPad 4 and lower

Please note that the app only supports portrait mode on mobile devices and tablets.

Still need help? Contact Us Contact Us